Jump to content

Can the HTC EVO LTE be forced to stay on LTE instead of switching to 3g?


cardboardbox
 Share

Recommended Posts

I'm in Houston, which is listed as being 70% completed but in reality I get poor speeds almost everywhere I go. Part of this is because my phone might show its on 4g but within a minute of doing anything on it, it will lose all data connection while it searches for a network. Then it will end up on 3g which is one tiny step up from useless. After a few minutes it will again lose connection while it works on switching to 4g and then the cycle will repeat itself. Everytime it switches from 4g to 3g or even 1x, I have no data connection for a maybe 10-15 seconds.

 

Is there a way to change a setting that will allow the phone to stay on 4g longer before switching to 3g? Even if its completely lost the LTE signal, I'd rather wait 10-15 seconds for the phone to get back on 4g rather than waste time on 3g and then waste more time switching back to 4g.

Link to comment
Share on other sites

I'm pretty sure there was a topic about this regarding the EVO LTE, as far as the ONE X I'm not sure.

 

 

http://s4gru.com/ind...connection-fix/

 

Here is the link regarding the LTE "Fix"

 

Hope it helps.

 

 

-Luis

Thanks! I actually did mean EVO LTE but I've gotten used to calling it One X since thats what its named for every other carrier. :(

 

Maybe a mod can clean up that title for me...

Link to comment
Share on other sites

Ah, you meant the EVO LTE? That makes more sense because the One X does not come in a Sprint compatible CDMA2000 variant.

 

Here is your solution:

 

*#*#4636#*#* > Phone info > LTE, CDMA

 

Let the baseband restart. And there you go, EV-DO is disabled.

 

AJ

  • Like 2
Link to comment
Share on other sites

Ah, you meant the EVO LTE? That makes more sense because the One X does not come in a Sprint compatible CDMA2000 variant.

 

Here is your solution:

 

*#*#4636#*#* > Phone info > LTE, CDMA

 

Let the baseband restart. And there you go, EV-DO is disabled.

 

AJ

thanks, going to give that a try today.
Link to comment
Share on other sites

Tried changing to "LTE/CDMA auto" but I still get a 3g connection (and 1x)

 

CDMA1X is 3G. Are you sure that your 3G connection is not CDMA1X?

 

Also, you appear to be running a third party ROM. In order for this method to work, you may need to be on a stock ROM.

 

AJ

Link to comment
Share on other sites

CDMA1X is 3G. Are you sure that your 3G connection is not CDMA1X?

 

Also, you appear to be running a third party ROM. In order for this method to work, you may need to be on a stock ROM.

 

AJ

I'm pretty sure that the rom I'm running isnt preventing the change from taking affect but when I am able, I'll try going back to stock and retrying. I dont know if my 3g connection is CDMA1X. I'm just going by the icon at the top that switches from 4g to 3g to 1x.

 

Sorry for the delay in replying... Had to put this aside for a few days while other priorities ate up my free time.

Link to comment
Share on other sites

  • 1 month later...
  • 4 weeks later...

Ah, you meant the EVO LTE? That makes more sense because the One X does not come in a Sprint compatible CDMA2000 variant.

 

Here is your solution:

 

*#*#4636#*#* > Phone info > LTE, CDMA

 

Let the baseband restart. And there you go, EV-DO is disabled.

 

AJ

Is there an app on the market that brings you to this screen?

 

Sent from my Nexus 7 using Tapatalk 2

 

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...