Jump to content
mikejeep

SignalCheck Beta Crew Forum

Recommended Posts

Still no 5G info showing on my s20+. Service mode shows I'm connected to n71. I can send more diagnostic reports if you want for both AT&T and T-Mobile. CellMapper is able to see that info on my phone so Samsung must either use different methods or they named them differently. Does anyone know anything about the CellMapper developer? I wonder if they'd share how they pull that info, SCP isn't exactly a competing app as it doesn't have a mapping part to it. Mike, not saying you wouldn't figure it out but it could save you time and headache.
For those that do see 5G info in SCP, does CellMapper show data similar to what my screenshot shows? a7208d1096b9c513c6d4418078a0b457.jpg1f337ec492bf6a6fb245d9184252a2e5.jpg

Sent from my SM-G986U using Tapatalk

Share this post


Link to post
Share on other sites
19 minutes ago, mdob07 said:
Still no 5G info showing on my s20+. Service mode shows I'm connected to n71. I can send more diagnostic reports if you want for both AT&T and T-Mobile. CellMapper is able to see that info on my phone so Samsung must either use different methods or they named them differently. Does anyone know anything about the CellMapper developer? I wonder if they'd share how they pull that info, SCP isn't exactly a competing app as it doesn't have a mapping part to it.

Please do send a diagnostic! Curious to see if anything I added behind the scenes will show new tidbits. Was really hoping you would see something when the system 5G icon was lit.

I have been in touch with Ivan from Cellmapper before, he was very friendly. I really like his app, I've been a premium subscriber for awhile and use it daily. But I consider our apps to be "competition" from the standpoint that they target the same userbase and have the same general intent, although they have different primary functions. I try to respectfully keep questions at a very broad level.

I do have some guesses about how to get more 5G data exposed. I have added a lot of trial and error guesswork behind the scenes -- that's where diagnostic reports come in handy when something isn't fully working. It's a challenge for me because I don't have a 5G test device -- a moot point because Sprint doesn't have any 5G coverage in my area. As TMO takes over, I'll probably try to get my hands on something once it would be useful. For now, I rely on you guys!

  • Like 1

Share this post


Link to post
Share on other sites
2 hours ago, mikejeep said:

Please do send a diagnostic! Curious to see if anything I added behind the scenes will show new tidbits. Was really hoping you would see something when the system 5G icon was lit.

I have been in touch with Ivan from Cellmapper before, he was very friendly. I really like his app, I've been a premium subscriber for awhile and use it daily. But I consider our apps to be "competition" from the standpoint that they target the same userbase and have the same general intent, although they have different primary functions. I try to respectfully keep questions at a very broad level.

I do have some guesses about how to get more 5G data exposed. I have added a lot of trial and error guesswork behind the scenes -- that's where diagnostic reports come in handy when something isn't fully working. It's a challenge for me because I don't have a 5G test device -- a moot point because Sprint doesn't have any 5G coverage in my area. As TMO takes over, I'll probably try to get my hands on something once it would be useful. For now, I rely on you guys!

Just sent a diagnostic report from both phones when on NR. If you want to add me into an alpha release to test feel free. 

  • Like 1

Share this post


Link to post
Share on other sites
On 5/10/2020 at 3:50 AM, mikejeep said:

A new SignalCheck beta has been pushed out and should be available shortly! It is focused on 5G improvements.. I still don't expect to see actual signal data yet, but there is now a possibility of seeing more information than previously. I have added several new status indicators; these descriptions are taken directly from some hidden Android routines:

  • Restricted: "camped on an LTE cell that supports E-UTRA-NR Dual Connectivity (EN-DC) but either the use of dual connectivity with NR (DCNR) is restricted or NR is not supported by the selected PLMN"
  • Not Restricted: "camped on an LTE cell that supports E-UTRA-NR Dual Connectivity (EN-DC) and both the use of dual connectivity with NR (DCNR) is not restricted and NR is supported by the selected PLMN"
  • Connected: "camped on an LTE cell that supports E-UTRA-NR Dual Connectivity (EN-DC) and also connected to at least one 5G cell as a secondary serving cell"

My educated guess is that many devices are showing the "5G" icon when any of these statuses are present, not just "Connected" -- hopefully this will help confirm that.

 

Configurable alerts for when an actual 5G connection is detected or lost have been also been added. These are similar to the LTE and SMR800 alerts already in the app. One difference is the "5G Found" status bar icon is a "5G" graphic so it should be clear when you connect. It is an "Alert" so it will only appear once, when the connection is made (if it's dropped and reconnected, you will be alerted again). That also means that it is not a true 5G "indicator" like the regular status bar icon because if you do not swipe away the alert notification, it will stay there forever (or if you do swipe it away, that doesn't necessarily mean you are no longer on 5G).

You can also continue to use the "LTE Custom Alert" to make your own 5G alerts for now, because any 5G information still displays in the app as text under in LTE section for.

I do not have a 5G device (or coverage), so I am relying on feedback from those of you who do. Let me know.. thanks!

 

From my understanding the 5G symbol displays on phones due to an Upperlayer packet being sent to tell the phone to display 5G , even without 5G being present. It is why you can see 5G NR band 5 on ATT, and not see a 5G symbol as the indicator. If you would like I work for ATT, and ny work shows a 5G indicator,  but has no NR, and Just up the street a few miles I get an LTR indicator, but have NR band 5 showing. Maybe it can help you out

Share this post


Link to post
Share on other sites

The latest update is working well for me on my LG V60 finding 5G-NR sites.  Love the update.  I also love the Dual Screen feature where I can run SCP in one screen and the Engineering Screen in the other.  Then cell mapper in the background.  I wish I had a phone like this years ago!

My only issue so far with the new Beta is that I had to disable the 5G lost/found chimes.  I don't know if it's the nature of the V60 or the T-Mobile 5G network, or just my local tower, but it so frequently goes in and out of 5G-NR at idle, even with a strong -70dBm signal, that the chimes were going off about 4-5 times per minute.  I was going bonkers.

Unfortunately, when I disable them, I also lose the large 5G icon on the status bar.  I'd like to be able to have that indicator without having to tie it to the found/lost sounds.  Otherwise, I'm very happy with the progress.  GREAT JOB!  :urock:

Robert

  • Like 2
  • Thanks 1

Share this post


Link to post
Share on other sites




My only issue so far with the new Beta is that I had to disable the 5G lost/found chimes.  I don't know if it's the nature of the V60 or the T-Mobile 5G network, or just my local tower, but it so frequently goes in and out of 5G-NR at idle, even with a strong -70dBm signal, that the chimes were going off about 4-5 times per minute. 


Yeah, it drops the NR carrier whenever the connection goes idle. Unlike Sprint where they basically kept CA active all the time (at least on B41). It's behaving more like CA on other providers, where it engages when needed, and then is dropped when usage drops.

Possibly you can have a flag to not show the alert again until the PCC changes. And/or until a certain time has elapsed without the NR indicator coming back.

Sent from my Pixel 4 XL using Tapatalk

  • Like 2

Share this post


Link to post
Share on other sites
16 hours ago, S4GRU said:

My only issue so far with the new Beta is that I had to disable the 5G lost/found chimes.  I don't know if it's the nature of the V60 or the T-Mobile 5G network, or just my local tower, but it so frequently goes in and out of 5G-NR at idle, even with a strong -70dBm signal, that the chimes were going off about 4-5 times per minute.  I was going bonkers.

Unfortunately, when I disable them, I also lose the large 5G icon on the status bar.  I'd like to be able to have that indicator without having to tie it to the found/lost sounds.  Otherwise, I'm very happy with the progress.  GREAT JOB! 

Very glad to hear it's working well for you! I will keep trying to improve them for other devices that apparently do not implement the native API routines. Could you send another diagnostic with the new beta so I can see if there's anything else being reported that I can get added?

Does your phone not have the option to display the 5G alert silently? That's how the existing SCP "status bar icons" are set up by default. "Alerts" and "status bar icons" are the names I gave them, but they are all just standard Android notifications with different settings.

I know some users wanted the "alert" type of icon so I will also add a 5G "status bar icon" type notification so it clears itself and is silent by default, similar to the current 1X and main icons. The alert was a bit of a quick and dirty addition, my main focus was trying to get 5G to show up at all.. baby steps!

  • Like 3

Share this post


Link to post
Share on other sites

I'm out in Southern Illinois today for work and this is the first time I've seen the 2nd B66 carrier notation. They use a different GCI pattern here than in Louisville. It got me wondering, would it be possible to move those variables that define the carrier notations to a table in the database that could be manipulated? That way more advanced users like most of us on here could change if needed to match our home market structure. AT&T seems to be different in each major metro area I've been in for B14 and 2nd and 3rd carriers on all bands. I haven't traveled enough with T-Mobile yet to see if they're consistent. I have no idea how much logic you have in the background to determine carriers now, just thought I'd throw the idea out there. The notarions help to make things easier to spot while driving but other than that its not a big deal it if its too much to do. ca30fd315218bc9fd82bcf386b590b54.jpg

Sent from my SM-G988U using Tapatalk

Share this post


Link to post
Share on other sites
14 hours ago, mikejeep said:

Could you send another diagnostic with the new beta so I can see if there's anything else being reported that I can get added?

I sent you two today when I was down in Longview, Washington.  Gee that town smells FUN-KAY.  Imagine burning dense wet cardboard.  And you cannot get away from the smell...anywhere.  Except to leave.

Robert

 

  • Like 4

Share this post


Link to post
Share on other sites

Noticed today that b71 gets stuck in the status bar. Sent diagnostics this afternoon. 

Share this post


Link to post
Share on other sites
9 hours ago, dkyeager said:

Noticed today that b71 gets stuck in the status bar. Sent diagnostics this afternoon. 

Taking off a band 71 alert had no effect. Basically need to exit and restart to solve it.  This on a rooted Moto G7 Power unlocked bootloader with original software, which I may update next week.

I live at the edge of 4 T-Mobile sites, one of which just got band 71, which my phone camps on. If I block band 71 with NSG, I get different sites in different parts of my home. SCP status indicator then works fine. SCP is rooted but does not use modem.  I have seen it move off b71 this morning. Rebooting numerous times yesterday did not help. Yesterday the b71 bandwidth was reduced from 15x15 to 10x10 as Covid-19 spectrum loans by Dish expired.

 

Share this post


Link to post
Share on other sites
On 5/14/2020 at 10:45 PM, dkyeager said:

Noticed today that b71 gets stuck in the status bar. Sent diagnostics this afternoon. 

The report you sent showed the app was displaying B2 and the icon at the time was also B2--I checked the graphics to make sure the B2 icon didn't actually say B71, LOL.. if it happens again send another report! I don't recall any recent reports of the notification icon falling out of sync with the app itself.

Share this post


Link to post
Share on other sites

New SignalCheck beta release was rolled out tonight and went live a couple hours ago.. some new goodies:

A shortcut to the Samsung Band Selector was added; I have no ability to test it myself so please let me know if it works.

A new option allows you to add a thin accent line to the LTE info block, which will be colored based on which provider you are connected to. I was trying to add something discreet to be able to quickly tell if I'm on Sprint or T-Mobile.. any feedback to improve this would be appreciated.

The best change is a significant increase in the amount of 5G information that the app can discover! Some recent diagnostic reports are showing some useful information, it looks like the latest Samsung update began reporting some new things. Please test and let me know if anything appears. Diagnostic reports are always useful because of the backend details I get.

Hopefully these all work well, let me know..

  • Like 3

Share this post


Link to post
Share on other sites
New SignalCheck beta release was rolled out tonight and went live a couple hours ago.. some new goodies:
A shortcut to the Samsung Band Selector was added; I have no ability to test it myself so please let me know if it works.
A new option allows you to add a thin accent line to the LTE info block, which will be colored based on which provider you are connected to. I was trying to add something discreet to be able to quickly tell if I'm on Sprint or T-Mobile.. any feedback to improve this would be appreciated.
The best change is a significant increase in the amount of 5G information that the app can discover! Some recent diagnostic reports are showing some useful information, it looks like the latest Samsung update began reporting some new things. Please test and let me know if anything appears. Diagnostic reports are always useful because of the backend details I get.
Hopefully these all work well, let me know..
I'm seeing "5G Status: Unknown (-99)" on both my phones regardless if its connected to NR or not. I set one phone to only B12 and its still there. I sent a diagnostic report from both phones, T-Mobile is on the May Android update, my AT&T phone is still on the April update. Also it does nothing when I tap on the Samsung Band Selector shortcut after I hit OK on the pop-up. Thanks for your continued efforts to get this working!8130678f39091e020d9c630657af4edf.jpg

Sent from my SM-G988U using Tapatalk

  • Like 1
  • Thanks 1

Share this post


Link to post
Share on other sites
37 minutes ago, mdob07 said:

I'm seeing "5G Status: Unknown (-99)" on both my phones regardless if its connected to NR or not. I set one phone to only B12 and its still there. I sent a diagnostic report from both phones, T-Mobile is on the May Android update, my AT&T phone is still on the April update. Also it does nothing when I tap on the Samsung Band Selector shortcut after I hit OK on the pop-up. Thanks for your continued efforts to get this working!

Doh.. your diagnostic reports are one of the things that helped me identify how to extract more 5G data. I only saw one new report from you but I'll see what I can tweak and hopefully get things working..

  • Like 1

Share this post


Link to post
Share on other sites

Accent seems to work fine on my Sprint LG V20 using Android 8. I have not tested it yet switch to T-Mobile or AT&T or Verizon etc.  No accent on my Moto G7 Power Unlocked and rooted with Android 9 on T-Mobile network using Red Pocket sim. I assume accent is triggered by PLMN, but maybe by sim carrier? Diags and beer money sent for both so you can compare if needed.

  • Thanks 1

Share this post


Link to post
Share on other sites
2 minutes ago, dkyeager said:

Accent seems to work fine on my Sprint LG V20 using Android 8. I have not tested it yet switch to T-Mobile or AT&T or Verizon etc.  No accent on my Moto G7 Power Unlocked and rooted with Android 9 on T-Mobile network using Red Pocket sim. I assume accent is triggered by PLMN, but maybe by sim carrier? Diags and beer money sent for both so you can compare if needed.

Hey thanks!! 🍻 I already saw your report and have been looking into it, I'm trying to get another release pushed out this morning to give you guys another try at everything for me.. the Red Pocket SIM caught my eye as the only oddity, although SCP identifies it as T-Mobile so it should show a magenta line. Did you try restarting the app after enabling the option, just in case? (You shouldn't have to do this but who knows). I'm adding some extra logging that should show me some more details why this might be missing. Stay tuned.

  • Like 2

Share this post


Link to post
Share on other sites

Yes I did restart app. Also rebooted Moto and turned off other signal apps. No accent.

Restarting app also was needed on LG V20 if you want to turn accent off (turn off setting then restart app needed).

Thanks

  • Sad 1

Share this post


Link to post
Share on other sites

Another beta is rolling out now, 4.613b.. I am trying something new with this release. It will only go to some of the Beta Crew, but those who get it should see it on Google Play much faster, perhaps within a few minutes. I targeted many of you who have provided recent 5G feedback. It contains fixes for color accent, 5G, and Samsung shortcuts that were part of last night's beta update. Please try all of the Samsung menu items and let me know which ones (if any) are useful! If there are bugs, send a diagnostic and note what's going on.. thanks!

  • Like 2

Share this post


Link to post
Share on other sites
5 minutes ago, mikejeep said:

Another beta is rolling out now, 4.613b.. I am trying something new with this release. It will only go to some of the Beta Crew, but those who get it should see it on Google Play much faster, perhaps within a few minutes. I targeted many of you who have provided recent 5G feedback. It contains fixes for color accent, 5G, and Samsung shortcuts that were part of last night's beta update. Please try all of the Samsung menu items and let me know which ones (if any) are useful! If there are bugs, send a diagnostic and note what's going on.. thanks!

Guess my 5G reporting days are over for a while soon. Doesn't sound like you ever got much of anything useful from my V50 anyway. Are Samsung devices where you are getting the most info? I'm not sure what my next device will be.. the S20 does not excite me much, and I'm not crazy about the curved screen on the OnePlus 8.

Also a question - the accent color does not show when I'm forced down to 1X or EVDO. It did show right away when I was on LTE and enabled it.

Share this post


Link to post
Share on other sites

Progress!!69f0cd59153b921745a96e177136cd54.jpg

Sent from my SM-G986U using Tapatalk

  • Like 1
  • Love 1

Share this post


Link to post
Share on other sites
Progress!!69f0cd59153b921745a96e177136cd54.jpg

Sent from my SM-G986U using Tapatalk


Its working on both phones, I sent a couple mode diagnostic reports. I dont see the band selector shortcut anymore though. I'm not seeing the accent color on either phone but I do have the option set to show it. a80d7ce59e463a76ee5849700c9d43aa.jpg29fb222803a13b92feb222bd772ba42d.jpg

Sent from my SM-G988U using Tapatalk

  • Like 1

Share this post


Link to post
Share on other sites
Its working on both phones, I sent a couple mode diagnostic reports. I dont see the band selector shortcut anymore though. I'm not seeing the accent color on either phone but I do have the option set to show it. a80d7ce59e463a76ee5849700c9d43aa.jpg29fb222803a13b92feb222bd772ba42d.jpg

Sent from my SM-G988U using Tapatalk

I did notice that the NR info sticks when I don't have an NR connection. bc0b561a3f692f10ea08bf273098e3d4.jpg

Sent from my SM-G988U using Tapatalk

Share this post


Link to post
Share on other sites

Another suggestion, can you place the 5G info above the neighbor cell list? In dense urban areas with 5x CA there will easily be enough neighbor cells to push the 5G info off the screen.6a68ca30cbeb1c85dc41481b915a9b51.jpg

Sent from my SM-G988U using Tapatalk

  • Like 1

Share this post


Link to post
Share on other sites
12 hours ago, mdob07 said:

Its working on both phones, I sent a couple mode diagnostic reports. I dont see the band selector shortcut anymore though. I'm not seeing the accent color on either phone but I do have the option set to show it.

I accidentally broke the Samsung menus when I compiled the latest release; it will be resolved in next update.

 

12 hours ago, mdob07 said:

I did notice that the NR info sticks when I don't have an NR connection.

Thanks, I'll look into that.. it's all a work in progress, glad we are making some headway!

 

5 hours ago, mdob07 said:

Another suggestion, can you place the 5G info above the neighbor cell list? In dense urban areas with 5x CA there will easily be enough neighbor cells to push the 5G info off the screen.

The current display format is temporary, it is just to get the data displaying reliably.. once that happens, it will get its own "block" like the connection other technologies have.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • large.unreadcontent.png.6ef00db54e758d06

  • gallery_1_23_9202.png

  • Similar Content

  • Posts

    • as of today band 25 being reduced on Sprint side, EARFCN 8321 is 5 MHz vs 8290 10 MHz here in LES. But when I forced roam to T-mobile it still 10 MHz band 2 EARFCN 750.
    • I sent mine back a few weeks ago. My power went out for 2 seconds and it went back to search mode. If the pebble gets disconnected from power for any amount of time, it needs to be completely re-configured. Decided it wasn't worth the hassle. I have wifi calling so I get phone calls and if I don't get texts,....depending on who it is from that's actually a bonus.
    • Just did some quick adding and 70% of the US population is in the largest 114 US MSAs. If Dish covered every MSA above 475k population (so, everything from Lafayette, LA on up), and service stopped completely outside MSA borders, they'd hit their 70%. That's while covering none of places as large as Reno, NV. Oh, and if you cover the San Juan, PR MSA, you can just hit the top 110 other MSAs, down to Pensacola, FL (so, everything with >= 500k population). Now, I fully expect Dish to omit some MSAs in the top 114 in favor of others that are closer to their footprint, or have more Boost Mobile user concentration, but this isn't a ridiculously huge lift...and is why Dish is saying they'll be building out only 15k cell sites by 2023...and they'll have help from T-Mobile as TMo casts off a bunch of redundant sites, many of which would love to immediately get a new tenant.
    • Thing is, building a coverage focused network to cover 70% of the US population using 600 isn't *that* expensive. It's the capacity play that's expensive. You need capacity if you have a ton of customers, which 10MM isn't. Alltel had 12 million customers when Verizon bought them, and covered a larger area than Dish will need to. If you spend $5 billion building a network for, say, 15 million customers, and don't have to subsidize those customers, that's not a huge outlay in the scheme of things.
  • Recently Browsing

    No registered users viewing this page.

×
×
  • Create New...