Jump to content
mikejeep

SignalCheck Beta Crew Forum

Recommended Posts

21 hours ago, mdob07 said:

Mike, my AT&T S9+ finally upgraded to Android 10. I'm seeing the CA values populate now, but I've not yet ever seen "BW: x MHz" Both are turned on in my display settings. If it knows the channel size for the CA list should the BW be populating also? I can send a diagnostic report if you want. 

8 hours ago, mdob07 said:

I just realized SNR is missing also. I've looked through multiple screenshots I've taken and haven't seen it at all.

5 hours ago, chamb said:

Yep, I have basic UNLOCKED s9 on Sprint.  Upgraded to Android 10.  No SNR and no BW. Aggregation is showing but not always correct.

Based on information I've received from other users, and mdob07's diagnostic report tonight, it's another issue related to the Samsung Android 10 update -- no bandwidth or SNR data is not being reported, so SignalCheck can't show anything. CA is separate from the bandwidth routine; its accuracy varies on all devices right now.. sometimes it's dead on, sometimes it's not. Android engineers unfortunately closed out my bug report about that and some other cell info issues as "working as intended".. will be trying to get them to reopen that.

 

21 hours ago, mdob07 said:

Also, I like how Android 10 shows more info on the swipe down than 9 did. Other than the known Android CA accuracy issue everything seems to be working fine. 

19 hours ago, UPdownLoAD said:

I'm still on Android 9 and I have the same issue since last update I believe. Miss the info

There is no way to adjust how much information appears in the notification shade pulldown.. the OS decides that. I'm not positive but it probably is some combination of screen resolution and how many other notifications of the same category are being displayed. If the display differs between Android 9 and 10 on the same device, they probably changed the "formula" used to decide how much to display. You should always be able to expand the notification to see all of the data though..?

 

21 hours ago, mdob07 said:

Found another one, sector ending 6B on AT&T is B12 small cell. I also hit sector ending 2A on the small cells in Nashville but that is already identified. There should be a third B12 sector but I haven't found it yet.

Thanks, I'll include that in the next update! Working on buttoning that up.. finally got GSM/WCDMA logging and neighbor note display fixed, I think. Dual SIM still a work in progress. Coming Soon™...

  • Like 4

Share this post


Link to post
Share on other sites
17 hours ago, mikejeep said:

Dual SIM still a work in progress. Coming Soon™...

🙏 Would be awesome!

  • Like 1

Share this post


Link to post
Share on other sites

New beta just uploaded, should appear on Google Play within an hour or two..

No dual-SIM support yet, but getting there. This version is mostly improvements for WCDMA connections (including PSC logging finally fixed so neighbor cells will work!) and some significant behind-the-scenes bugfixes focused on database functionality.

One significant addition is a LTE Cell ID Format option under Display Preferences where users can now toggle between hex GCI, decimal ECI, or a "hybrid" option that displays the typical hex sector bits but the rest of the ID is in decimal format. I am told that this should correlate to region/site identifiers for some providers..

Full changelog: https://signalcheck.app/change-log

If this version proves to be stable, it will become a public release within a few days. I appreciate everyone's support!

  • Like 5
  • Love 1

Share this post


Link to post
Share on other sites

Hey has anyone noticed an increase battery usage?  I happen to look today, and it was using 45% my battery went from 100 to zero in 5 hrs tonight... Don't nothing out of the norm

 

Note 8

Share this post


Link to post
Share on other sites

New beta update will become available shortly.. only notable change from the last beta is that the cell information displayed on the popup when editing a site note is more useful. A public update is also rolling out tonight that will include all of the fixes from the last two beta versions thanks to all of your help. I appreciate it!

  • Like 7

Share this post


Link to post
Share on other sites

Already pushed out a new beta this afternoon! When exporting logs, the LTE cell ID will now be formatted to match whatever your preference is (hex/decimal/hybrid). Also fixed WCDMA neighbor cells not reporting valid signal strength.

The biggest changes were behind the scenes and not visible to end users, but were fairly significant in terms of potential impact.. I wanted to share it fairly quickly so I can make sure I didn't break anything before I continued working on other things.. if anything appears to have gotten worse, let me know.. I'll be watching for automated crash reports too. Thanks!

  • Like 3

Share this post


Link to post
Share on other sites

Slightly different request for help today.. I have finally(!!!) updated SignalCheck Lite, after several years of dormancy. It was stable and didn't need a lot of changes until Android 10 made it completely unusable. Anyone on the SCP Beta Crew is automatically able to opt-in for the Lite Beta as well. The update (version 4.572Lb) should be available shortly.. could you please take a few minutes to install and test it, to make sure it is stable?

https://play.google.com/apps/testing/com.blueline.signalchecklite (edited link)

The code is nearly identical to Pro, but with many components removed. Once you verify it is working, you can uninstall Lite to minimize confusion. Please send me a brief comment (here, PM, email, whatever) after you give it a try and let me know how it looks. I do not expect any issues, but I want to make sure it is stable before it goes out. Thanks!

  • Like 2

Share this post


Link to post
Share on other sites
50 minutes ago, mikejeep said:
Slightly different request for help today.. I have finally(!!!) updated SignalCheck Lite, after several years of dormancy. It was stable and didn't need a lot of changes until Android 10 made it completely unusable. Anyone on the SCP Beta Crew is automatically on the Lite Beta Crew as well. The update should be available shortly.. could you please take a few minutes to install and test it, to make sure it is stable?

https://play.google.com/store/apps/details?id=com.blueline.signalchecklite

The code is nearly identical to Pro, but with many components removed. Once you verify it is working, you can uninstall Lite to minimize confusion. Please send me a brief comment (here, PM, email, whatever) after you give it a try and let me know how it looks. I do not expect any issues, but I want to make sure it is stable before it goes out. Thanks!

 

Edit: whoops, looks like I haven't gotten the update yet. Lol the cart ran over the horse.

Sent from my SM-G965U using Tapatalk

 

 

 

  • Like 1

Share this post


Link to post
Share on other sites
3 minutes ago, mdob07 said:

Mike, I sent a diagnostic report from SC Lite, on my S9+ AT&T on Android 10 it shows no connection when connected to LTE. I tried closing and reopening the app, and cycled airplane mode with no change. SCP is working fine.

Thanks! Is that the new version released today? I'm not sure if it became available yet.. should be version 4.572Lb? Please send me a diagnostic report if it is.

Share this post


Link to post
Share on other sites
Thanks! Is that the new version released today? I'm not sure if it became available yet.. should be version 4.572Lb? Please send me a diagnostic report if it is.
I thought about that after I posted, I assumed it was the newest version since I had to install it, but it looks like the update hasn't hit the play store yet. That was on 4.482. I'll test again once the update is available. Sorry for any confusion.

Sent from my SM-G965U using Tapatalk

Share this post


Link to post
Share on other sites
25 minutes ago, mdob07 said:

I thought about that after I posted, I assumed it was the newest version since I had to install it, but it looks like the update hasn't hit the play store yet. That was on 4.482. I'll test again once the update is available. Sorry for any confusion. emoji2957.png

No worries! I kind of jumped the gun by posting before it was published and should have been more clear, sorry about that. It's completely separate from SignalCheck Pro, so most of you won't have it installed already.

EDIT: It should be live now, but ensure you're enrolled in the beta and see version 4.572Lb.

Share this post


Link to post
Share on other sites

Finally got the update, looks good.

Sent from my SM-G965U using Tapatalk

 

 

 

d186afc7ba58fb771e5c78ca4f0224a5.jpg

  • Like 2

Share this post


Link to post
Share on other sites
2 hours ago, mdob07 said:

Finally got the update, looks good.

Sent from my SM-G965U using Tapatalk

 

 

 

d186afc7ba58fb771e5c78ca4f0224a5.jpg

I just now noticed that it says SignalCheck Pro at the top, not sure if you want that to say Lite for the lite version. Also, since most of the people that install the lite version will be new to the app it may be a good idea to have a pop up message the first time it opens that the user has to acknowledge about the CA values being hit or miss (as well as any other Android quirks), and that its a known Android issue. 

  • Like 2

Share this post


Link to post
Share on other sites
I just now noticed that it says SignalCheck Pro at the top, not sure if you want that to say Lite for the lite version. Also, since most of the people that install the lite version will be new to the app it may be a good idea to have a pop up message the first time it opens that the user has to acknowledge about the CA values being hit or miss (as well as any other Android quirks), and that its a known Android issue. 


Thank you very much! Definitely didn't notice the Pro at the top, so used to seeing that.. I'm still wrestling with the best approach for BW, CA, and TA, since they can be quirky and are more "bonus" features good to keep on the Pro side. But it's also nice to not frustrate users who upgrade expecting it to be flawless. Debating between an explanatory pop-up and adding a limited Preferences menu on Lite so users won't see it until they enable it, where I can out explanatory text like I do for Pro.
  • Like 1

Share this post


Link to post
Share on other sites


Thank you very much! Definitely didn't notice the Pro at the top, so used to seeing that.. I'm still wrestling with the best approach for BW, CA, and TA, since they can be quirky and are more "bonus" features good to keep on the Pro side. But it's also nice to not frustrate users who upgrade expecting it to be flawless. Debating between an explanatory pop-up and adding a limited Preferences menu on Lite so users won't see it until they enable it, where I can out explanatory text like I do for Pro.
Looks good in the most recent update. I like how you laid the menu out and show what they can unlock if they go pro.a24980f3a25ae803f562436819570e41.jpg0b0780e233fc87f0dbf3c45226091ff9.jpg

Sent from my SM-G965U using Tapatalk

  • Thanks 1

Share this post


Link to post
Share on other sites

Mike, I'm having trouble importing my log file onto my new S20. Not sure if it's an app issue or phone issue. All of the permissions look correct. I've tried uninstalling and reinstalling with no affect. When I tap on import logs it pops up the black screen with the 2 dots up top and nothing else, if I tap the 2 dots I get 3 options, but all three are blank as well. When I check the signal check folder using Samsungs file explorer I see the log file there. Thoughts?a3161d5d31430b23499f99fd56f0bd7f.jpg65336c5ef9642a0cc81c5102c2add6a9.jpg06ca261d78b8d51aa2c0d8f69eb84d8a.jpg

Sent from my SM-G965U using Tapatalk

  • Thanks 1

Share this post


Link to post
Share on other sites
On 3/3/2020 at 12:59 PM, mdob07 said:
Mike, I'm having trouble importing my log file onto my new S20. Not sure if it's an app issue or phone issue. All of the permissions look correct. I've tried uninstalling and reinstalling with no affect. When I tap on import logs it pops up the black screen with the 2 dots up top and nothing else, if I tap the 2 dots I get 3 options, but all three are blank as well. When I check the signal check folder using Samsungs file explorer I see the log file there. Thoughts?

Sent from my SM-G965U using Tapatalk

 

I just tried exporting my log on the S20 with one site to see if I could see it to import back and I get a permission denied error when trying to export the log. Assuming that's why I can't see the log to import either. 1053cb58126437c3e6b330f520c0425b.jpg

CQbfO1hl.png
Sent from my SM-G965U using Tapatalk

  • Thanks 1

Share this post


Link to post
Share on other sites
On 3/3/2020 at 12:59 PM, mdob07 said:

Mike, I'm having trouble importing my log file onto my new S20. Not sure if it's an app issue or phone issue. All of the permissions look correct. I've tried uninstalling and reinstalling with no affect. When I tap on import logs it pops up the black screen with the 2 dots up top and nothing else, if I tap the 2 dots I get 3 options, but all three are blank as well. When I check the signal check folder using Samsungs file explorer I see the log file there. Thoughts?

Sent from my SM-G965U using Tapatalk
 

 

On 3/3/2020 at 1:05 PM, mdob07 said:

I just tried exporting my log on the S20 with one site to see if I could see it to import back and I get a permission denied error when trying to export the log. Assuming that's why I can't see the log to import either.
Sent from my SM-G965U using Tapatalk
 

FWIW I get the same errors on my Sprint S9+, but do not get it on my AT&T S9+. Not sure what would be different between them, all 3 are on Andriod 10 with February 1st security update. 

  • Like 1

Share this post


Link to post
Share on other sites
On 3/3/2020 at 12:59 PM, mdob07 said:

Mike, I'm having trouble importing my log file onto my new S20. Not sure if it's an app issue or phone issue. All of the permissions look correct. I've tried uninstalling and reinstalling with no affect. When I tap on import logs it pops up the black screen with the 2 dots up top and nothing else, if I tap the 2 dots I get 3 options, but all three are blank as well. When I check the signal check folder using Samsungs file explorer I see the log file there. Thoughts?

Sent from my SM-G965U using Tapatalk
 

 

On 3/3/2020 at 1:05 PM, mdob07 said:

I just tried exporting my log on the S20 with one site to see if I could see it to import back and I get a permission denied error when trying to export the log. Assuming that's why I can't see the log to import either. 


Sent from my SM-G965U using Tapatalk

 

On 3/3/2020 at 4:58 PM, mdob07 said:

 

FWIW I get the same errors on my Sprint S9+, but do not get it on my AT&T S9+. Not sure what would be different between them, all 3 are on Android 10 with February 1st security update. 

It occurred to me today to try using Samsung's SmartSwitch app to try to restore SCP from my old S9+ to my S20 Ultra. I was able to get it to finally transfer but I had go into app settings and clear cache, clear data, then uninstall SCP on my new phone. Then once I restored SCP from my S9+ to my Ultra it installed the app as part of the transfer and the DB came with it. Originally when I set my new phone up I did it from scratch. 

It still won't let me export site logs or the log DB. Importing still does the same also. At least this way I have my sites notes back.

  • Thanks 1

Share this post


Link to post
Share on other sites
On 3/3/2020 at 4:58 PM, mdob07 said:

FWIW I get the same errors on my Sprint S9+, but do not get it on my AT&T S9+. Not sure what would be different between them, all 3 are on Andriod 10 with February 1st security update. 

Thank you for all the detailed info.. I'm suddenly getting a lot of messages like this, and I don't know why. The diagnostic reports aren't showing any crashes and all appropriate permissions are granted. The issue appears to be limited to some Android 10 devices but not all, but I can't figure out why. I'll keep digging into it and hopefully have some answers soon.

  • Like 1

Share this post


Link to post
Share on other sites
1 hour ago, mikejeep said:

Thank you for all the detailed info.. I'm suddenly getting a lot of messages like this, and I don't know why. The diagnostic reports aren't showing any crashes and all appropriate permissions are granted. The issue appears to be limited to some Android 10 devices but not all, but I can't figure out why. I'll keep digging into it and hopefully have some answers soon.

I discovered the problem and will be working on it, but it will likely be several days before I have something ready for beta testing.

  • Like 3

Share this post


Link to post
Share on other sites

I put SCP in Diagnostic mode and tried exporting logs, exporting DB, and importing logs. Captured this screenshot incase its helpful. I already had this done when I saw your post about finding the problem. 

http://imgur.com/a/8UPXVpx

  • Thanks 1

Share this post


Link to post
Share on other sites

I may have found a band-aid fix that will resolve the import/export issue temporarily. New beta release is processing and should be available on Google Play within the next hour or so. I also decided to unveil some very basic 5G data, although I do not expect many devices to see it yet. It will appear below the LTE information if there is any data available; please send a diagnostic report if you see it!

  • Like 3
  • Love 1

Share this post


Link to post
Share on other sites
I may have found a band-aid fix that will resolve the import/export issue temporarily. New beta release is processing and should be available on Google Play within the next hour or so. I also decided to unveil some very basic 5G data, although I do not expect many devices to see it yet. It will appear below the LTE information if there is any data available; please send a diagnostic report if you see it!
Import/export is working on both of my phones now.
I didn't see any NR info coming through on SCP this morning. I did notice that Cellmapper is showing RSRP and some other stats on my S20 Ultra, but I have no idea how its getting that info. I didn't think to send a diagnostic report this morning but I did send one back on Wednesday when connected to N5.
(If the screenshots are huge I'll resize them when I get home to my desktop)151ccecb0175e59b2221344e81a364bb.jpg4e69a18db48ef190e81d014c4120abd9.jpg2bd350a5d9aeee951a096fc504b9c290.jpg77299437ef827dd5e072ec8c5b1ce28f.jpg

Sent from my SM-G988U using Tapatalk

  • Like 2

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...