Jump to content
mikejeep

SignalCheck Beta Crew Forum

Recommended Posts

On 12/9/2018 at 9:55 PM, mdob07 said:

Hey Mike,  would it be possible to change SCP to identify AT&T B14 by EARFCN vs GCI pattern? After doing some analysis on my log, looking the the B14 thread on Howard Forums and the netmapper map it appears to wildly vary by market what AT&T used for B14 sectors. The EARFCN should be consistent across the country. This would keep you from having to set several different patterns for B14.

The app already uses EARFCN as the primary means to identify the LTE band.. it will try to match a GCI pattern first, but if there are no matches or the "guessed" band does not match EARFCN data that appears to be valid, it uses the EARFCN instead. Since there are so many B14 sector possibilities right now, I don't think I will continue adding them beyond what is programmed now. Most newer devices on newer Android builds are properly reporting EARFCN, with some exceptions (issues with B66/B71 most notably). GCI pattern matching has become most useful to identify "special" cells (MM/SC/MB/Airave/etc) as well as multiple carriers.

 

3 hours ago, Jesito473 said:

Just noticed this today (MM2/SC2) anyone else?

I know this was answered elsewhere, but for the benefit of anyone who comes along later -- a small cell second carrier has been identified that follows the same GCI pattern as one sector of a Mini-Macro second carrier. Since the app has no way to know which one it is, it displays both indicators when this occurs.

-Mike

  • Like 2

Share this post


Link to post
Share on other sites
I know this was answered elsewhere, but for the benefit of anyone who comes along later -- a small cell second carrier has been identified that follows the same GCI pattern as one sector of a Mini-Macro second carrier. Since the app has no way to know which one it is, it displays both indicators when this occurs.
-Mike

Thank you Mike one of the guys clarified it. Good to know I wasn’t seeing things lol


Sent from my iPhone using Tapatalk
  • Like 1

Share this post


Link to post
Share on other sites
35 minutes ago, mikejeep said:

 Since the app has no way to know which one it is, it displays both indicators when this occurs.

-Mike

At least in Samsung markets with AirHarmony small cells, the PCI of small cells is 450 or greater.  EARFCN would be another way, but that sometimes gets location specific. GCI  would be another way, but then you would need to know the MM cutoff point for each market (we have those for Ohio)

Share this post


Link to post
Share on other sites

Mike,

Can you add something to make T-Mobile (310260) notes show up when roaming from Sprint (311490)?

  • Like 1

Share this post


Link to post
Share on other sites
Mike,
Can you add something to make T-Mobile (310260) notes show up when roaming from Sprint (311490)?
Not sure what you're asking.. could you clarify? Any saved notes should appear regardless if you're roaming or not. If you are referring to neighbor cells, there's already an option to ignore the PLMN for neighbor notes.

-Mike

Share this post


Link to post
Share on other sites
1 hour ago, mikejeep said:

Not sure what you're asking.. could you clarify? Any saved notes should appear regardless if you're roaming or not. If you are referring to neighbor cells, there's already an option to ignore the PLMN for neighbor notes.

-Mike

T-Mobile uses Clearwire 311490 as a secondary PLMN on their sites to enable Sprint roaming. I'm asking if you can make notes from 310260 show up for 311490, similar to what you are doing with 310120 and 312530.

 

Screenshot_20181218-220415.png

Share this post


Link to post
Share on other sites
T-Mobile uses Clearwire 311490 as a secondary PLMN on their sites to enable Sprint roaming. I'm asking if you can make notes from 310260 show up for 311490, similar to what you are doing with 310120 and 312530.


Ahh I see.. are you on the latest beta release, or the public one? (This is the beta thread.) I do not believe the beta will show 311490 any more. I'm trying to finish squashing a couple significant bugs so I can get a public update out with this improvement very soon.

-Mike

Share this post


Link to post
Share on other sites
6 hours ago, mikejeep said:

Ahh I see.. are you on the latest beta release, or the public one? (This is the beta thread.) I do not believe the beta will show 311490 any more. I'm trying to finish squashing a couple significant bugs so I can get a public update out with this improvement very soon.

Public channel. You're saying under the latest beta, if I'm a Sprint user, and I roam onto T-Mobile which presents itself as 311490 on the tower, and I already have a note saved for the same GCI under T-Mobile 310260, I'll be able to see that note?

Share this post


Link to post
Share on other sites
Public channel. You're saying under the latest beta, if I'm a Sprint user, and I roam onto T-Mobile which presents itself as 311490 on the tower, and I already have a note saved for the same GCI under T-Mobile 310260, I'll be able to see that note?
Correct! At least it should based on testing so far.. submit a diagnostic report (About > Send Diagnostics) next time you're on a 311490 TMo site and I should be able to confirm for you.

-Mike

Share this post


Link to post
Share on other sites

Some devices are reporting 311490 on T-Mobile no matter what I try, but most are not. I will continue looking to figure out a way to make those scenarios work better with "real" T-Mobile site notes logged under 310260.

A minor beta update is pushing out now, should be available shortly. It adds AT&T B2 small cells and fixes an issue with cached diagnostic reports not sending. More significantly, a public release is also going out that catches up all the changes the crew has been testing for the past 6-8 weeks. Thank you all for your help, I appreciate it!

-Mike

  • Like 6

Share this post


Link to post
Share on other sites

New beta has been uploaded, should become available within the hour.. added LTE timing advance and hopefully squashed some big juicy bugs.. let me know! Please try enabling some notifications and changing the sounds too..

-Mike

  • Like 4

Share this post


Link to post
Share on other sites

New update looking good on my S9+ so far.

  • Like 1

Share this post


Link to post
Share on other sites
7 hours ago, mikejeep said:

Please try enabling some notifications and changing the sounds too..

-Mike

Changing sounds doesn't change the sound played it is just my normal notification sound.

Share this post


Link to post
Share on other sites

I got the Android Pie update on my S9+ last night. Everything looks good with SCP.725449621ce3d4be007ede813d288891.jpg

Sent from my SM-G965U using Tapatalk

  • Like 3

Share this post


Link to post
Share on other sites

Mike, just noticed on my S9+ that SCP showed no connection in both the app and task bar when connected to HSPA+. Cycled airplane mode and its showing everything for LTE with no issues. I'll try to get it back to HSPA+ to do more testing later.cbca8aef9c59c88d9431dee048db89d0.jpgbfe6266dd47fa625c5d456bb9c9c56e4.jpg

Sent from my SM-G965U using Tapatalk

Share this post


Link to post
Share on other sites

Hoping for a new beta soon, just updated to the Android Q beta and SCP isn't displaying any data

Share this post


Link to post
Share on other sites

Happy Birthday mikejeep!

Sent from my SM-N920P using Tapatalk

  • Like 1

Share this post


Link to post
Share on other sites
On 3/13/2019 at 8:24 PM, jefbal99 said:
Hoping for a new beta soon, just updated to the Android Q beta and SCP isn't displaying any data

I have spent a TON of time on it because I'm overhauling Alerts for Android 8+ users. They were broken and I don't want to push another update out without a fix. It's a lot of work but it's getting there.

Send me a diagnostic report from the Q Preview so I can get a peek at what's broken. Most early Preview builds have caused issues that were eventually resolved before the stable launch.

And thanks for the bday wishes!!

-Mike

  • Like 3

Share this post


Link to post
Share on other sites
1 minute ago, mikejeep said:

 

I have spent a TON of time on it because I'm overhauling Alerts for Android 8+ users. They were broken and I don't want to push another update out without a fix. It's a lot of work but it's getting there.

 

Send me a diagnostic report from the Q Preview so I can get a peek at what's broken. Most early Preview builds have caused issues that were eventually resolved before the stable launch.

 

And thanks for the bday wishes!!

 

-Mike

 

I sent one in last night, let me know if you need another

  • Like 1

Share this post


Link to post
Share on other sites

After looking at a handful of diagnostic and crash reports that I have received from Android Q Preview users, I can see that the connection data being reported by the OS is either missing or invalid on all devices so far. It's either broken or Android is taking a completely different approach and has not publicly shared that yet. Hopefully it's just broken, and they will resolve it in the next release.

Q users, please use whatever reporting channels are in place to report Preview bugs to inform them of this. You can mention that onSignalStrengthsChanged() is including header text with every value instead of just the raw data, and CellInfoLte.getCellIdentity() and related routines appear to be reporting no data.

-Mike

Share this post


Link to post
Share on other sites
12 hours ago, mikejeep said:

After looking at a handful of diagnostic and crash reports that I have received from Android Q Preview users, I can see that the connection data being reported by the OS is either missing or invalid on all devices so far. It's either broken or Android is taking a completely different approach and has not publicly shared that yet. Hopefully it's just broken, and they will resolve it in the next release.

Q users, please use whatever reporting channels are in place to report Preview bugs to inform them of this. You can mention that onSignalStrengthsChanged() is including header text with every value instead of just the raw data, and CellInfoLte.getCellIdentity() and related routines appear to be reporting no data.

-Mike

It's on reddit now.  Please comment and upvote https://www.reddit.com/r/android_beta/comments/b2n6z5/connection_data_not_being_reported_from_q/

  • Like 2

Share this post


Link to post
Share on other sites
16 hours ago, jefbal99 said:

Google responded on reddit, looks like it will be addressed :)

  • Like 4

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...