Jump to content

Recommended Posts

It's carrier unlocked for sure. I have to get my TMO sim from my daughters phone and try it.

 

Sent from my LGLS990 using Tapatalk

 

When you say your phone can do this now, it's probably good to know for sure :)    

 

Where did you hear it's unlocked?  Usually Sprint phone are unlocked for International SIMs but not for other domestic carriers.  

Also, from the LS990 specs, it doesn't appear that the Sprint G3 contains LTE bands for any other US carriers other than Sprint, so even if it was domestically unlocked , best we can get is 3G on other carriers.  

 

The Nexus 5 is unlocked for all carriers, and has the correct LTE bands for TMO, ATT.  It would be great if you discover that the G3 is the same way, but from what I read, it's not. 

Share this post


Link to post
Share on other sites

It works on Verizon but only 3G. I just popped in my friends sim. Completed phone calls and texts. Will be trying ATT shortly, and TMO later this week when I get my other sim. Its prepaid tho so I dunno. I also will be trying a Net10 sim. I hacked the unlock myself from a combination of methods from around the internet and some creative ShortCut Master work. If I had to list all steps I couldn't because I don't remember everything. Ive heard conflicting reports about these radios. I might try some different PRLs. And also gonna try to access the gsm main menu with a gsm sim but Im not very hopeful there.

 

Sent from my LGLS990 using Tapatalk

Share this post


Link to post
Share on other sites

So does this need a carrier unlock from Sprint or should any Sprint G3 work with other carriers. ?   

 

Curious if I can take this phone to Europe without having to get Sprint to unlock it first.

Share this post


Link to post
Share on other sites

So does this need a carrier unlock from Sprint or should any Sprint G3 work with other carriers. ?   

 

Curious if I can take this phone to Europe without having to get Sprint to unlock it first.

 

sinisin rooted and unlocked things on his own. 

 

Those steps are not recommended unless you really know what you are doing.

 

In order for your G3 to work internationally, you will need Sprint to internationally unlock it. Otherwise it will reject sim cards that are not Sprint. 

Share this post


Link to post
Share on other sites

SCP Running VZW Sim.

 

Sent from my LGLS990 using Tapatalk

I thought that the SIM was only used for LTE.  1X/eHRPD is still connecting to Sprint.  Try calling 611 and see if it's Verizon or Sprint.

Share this post


Link to post
Share on other sites

I hope Sprint and Lg pushed a update to fix the headphone Jack errors, I can't even use headphones or my aux cable 99% of the time. Very annoying.

 

Sent from my LG G3.

yup i have been having problems to...thought it was the cord.....uhhh nope its the phone, you have to unplug and replug it in.....i dont think its a update fixable thing though....Because when you bump it, it messes up......

 

might have to take it into store

Share this post


Link to post
Share on other sites

yup i have been having problems to...thought it was the cord.....uhhh nope its the phone, you have to unplug and replug it in.....i dont think its a update fixable thing though....Because when you bump it, it messes up......

 

might have to take it into store

I was hoping for a update to see if that fixes it first.

 

Sent from my LG G3.

Share this post


Link to post
Share on other sites

I was hoping for a update to see if that fixes it first.

 

Sent from my LG G3.

but if its hardware related, how can a update fix it??

 

because wiggles or bumping screwing it up sounds like a plug issue

Share this post


Link to post
Share on other sites

but if its hardware related, how can a update fix it??

 

because wiggles or bumping screwing it up sounds like a plug issue

Yeah I'm leaning towards some units being defective. When I bought my HTC one m8 straight out it had a defective radio( my luck haha) but mine seems to disconnect. When I plug it into my trucks radio it will recognize it but when I click play on Pandora it disconnects for some reason.

 

Sent from my LG G3.

Share this post


Link to post
Share on other sites

but if its hardware related, how can a update fix it??

 

because wiggles or bumping screwing it up sounds like a plug issue

Yeah I'm leaning towards some units being defective. When I bought my HTC one m8 straight out it had a defective radio( my luck haha) but mine seems to disconnect. When I plug it into my trucks radio it will recognize it but when I click play on Pandora it disconnects for some reason.

 

Sent from my LG G3.

Share this post


Link to post
Share on other sites

I thought that the SIM was only used for LTE. 1X/eHRPD is still connecting to Sprint. Try calling 611 and see if it's Verizon or Sprint.

I didn't need too. The 3G switched to the network sim I had in. Caller ID showed as the number assigned to the test sims. And if it wasn't unlocked those sims wouldn't have worked at all......

 

And yes my phone is rooted and I hacked the unlock myself. It's not something I can share yet as I have some bugs to work out like having to dial 1 before any US number or phone app crashes. I also need to remember what I did exactly as it was a combo of 4 methods from around the internet. I'm probably gonna return to stock and start over because my system is heavily modified and Im running custom UI components. Need to make sure none of that is giving me the phone crash issue.

 

Sent from my LGLS990 using Tapatalk

Share this post


Link to post
Share on other sites

Yeah I'm leaning towards some units being defective. When I bought my HTC one m8 straight out it had a defective radio( my luck haha) but mine seems to disconnect. When I plug it into my trucks radio it will recognize it but when I click play on Pandora it disconnects for some reason.

 

Sent from my LG G3.

mine did that for a portable speaker i had.....plugged it in, showed the line cord, then the head phone then disconnected...took me about 5 minutes of in n out..(ok sounded wrong but you know what i mean)   and then it took..

 

i think i am going to google it see if its a known issue....have you??

Share this post


Link to post
Share on other sites

mine did that for a portable speaker i had.....plugged it in, showed the line cord, then the head phone then disconnected...took me about 5 minutes of in n out..(ok sounded wrong but you know what i mean) and then it took..

 

i think i am going to google it see if its a known issue....have you??

I remember reading on some forum about a quite a few had the issue. I haven't tried the plug and unplug until it works method. I just plug it in and if it doesn't work then I use Bluetooth but doesn't sound as good. Mine might work 2 out of 10 tries. But if I plug in a headset or headphones it works like a champ. Only the aux is giving me problems so far.

 

Sent from my LG G3.

Edited by ghostkilla1388

Share this post


Link to post
Share on other sites

#6   http://www.androidauthority.com/lg-g3-problems-517832/

 

http://forums.androidcentral.com/lg-g3/415737-serious-sound-issues-through-lg-g3-headphone-jack-aux.html

 

 

interesting read on the 2nd one.....more so the licking part....

 

anyway maybe it is a software glitch.....

 

ohhhh and the fact it is so quiet is bugging me to......my note 2 would blast me out, could only run 3/4 on the volume with headset.....i HAVE to go full with this...

 

went and got viper for android and it has helped a little....

 

for $600 bones my shit better work flawless....maybe i will go squeeze the store

Share this post


Link to post
Share on other sites

If you're rooted there is an easy sound boost mod that works great. It with Viper is on par with your Note. I'll post the link when I can track it down.

 

Sent from my LGLS990 using Tapatalk

Share this post


Link to post
Share on other sites

I remember reading on some forum about a quite a few had the issue. I haven't tried the plug and unplug until it works method. I just plug it in and if it doesn't work then I use Bluetooth but doesn't sound as good. Mine might work 2 out of 10 tries. But if I plug in a headset or headphones it works like a champ. Only the aux is giving me problems so far.

 

Sent from my LG G3.

I just tried my G3.  Like yours, it works great with headphones.  When plugging in a portable speaker, it's hit or miss.  Using the plug and unplug method can get it to work, but the speaker picks up "screen noise".  I haven't tried AUX in my car, as I always use Bluetooth, but I suspect the same.

 

Do these manufacturers even bother to alpha test this stuff?  They had to know this problem existed before release.  I would say that consumers are the new beta testers, but I really believe we are the alpha testers.  You should be able to place a 3.5 mm plug into the jack on the G3 and whatever device you plug in should work - whether it be a speaker, AUX or headphones.  We should not have to go to extremes buying special cables and wasting our time plugging and unplugging to get the damn thing to work!

 

Manufacturers just want to get the stuff to market nowadays.  They don't appear to care if the devices work properly or not.

 

Hopefully a fix will come soon. 

Share this post


Link to post
Share on other sites

That's the only reason I'm thinking it's a software issue. My Bose, Sony, and Yurbuds all work fine no problems or weird noises. But when I plug it into my truck it sees the cord as being plugged it but as soon as I try to play anything on Pandora or Google play music app it disconnects and plays through the phone. I do have a cheap wind up cable but it has work fine for my Galaxy S5 and One M8.

 

Sent from my LG G3.

Share this post


Link to post
Share on other sites

That's the only reason I'm thinking it's a software issue. My Bose, Sony, and Yurbuds all work fine no problems or weird noises. But when I plug it into my truck it sees the cord as being plugged it but as soon as I try to play anything on Pandora or Google play music app it disconnects and plays through the phone. I do have a cheap wind up cable but it has work fine for my Galaxy S5 and One M8.

 

Sent from my LG G3.

I agree with you.  I do believe it's a software issue.  The G3 would not mechanically connect to one device and not another unless there was some sort of EXTREME impedance mismatch.

 

I tried connecting the G3 to a vacuum tube headphone amplifier that I have.  That worked flawlessly.  The G3 saw the tube amp as a line output.  The G3 does tend to put out some RF noise or LCD noise though.   

Share this post


Link to post
Share on other sites

Love the vacuums amps. Good old sounding amps, I love a good clean sound. Haha

 

Sent from my LG G3.

Share this post


Link to post
Share on other sites

Here is a link to an app called SoundAbout in Google Play.  Some individuals who are having issues with LG's (G3) crappy resistance based output jack detection programming say it puts a Band-Aid on the issue.  I haven't had the chance to try it yet myself.  Good Luck!

 

https://play.google.com/store/apps/details?id=com.woodslink.android.wiredheadphoneroutingfix

Share this post


Link to post
Share on other sites

d88be8c9c121830debb726a885262c82.jpg

Has anyone gotten this error, it's been popping up a lot today, just started today too.

 

Sent from my LG G3.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...