Jump to content
WiWavelength

HTC/Google Pixel and Pixel XL Users Thread

Recommended Posts

lordsutch    840

Somehow - very long story short - my Pixel XL seems to be provisioned for Sprint in such a way that it will only connect to 3G (the phone definitely connects to LTE with a Project Fi SIM installed on both Sprint and T-Mobile, so it's not a hardware problem). This has baffled everyone I've talked to at Sprint; we've tried everything (72787, PRL updates, device config updates...). In the hidden radio info screen I've tried wedging it into LTE-only mode and LTE cell information shows up under the "Cell Measurement Info," but for whatever reason it won't register on the network.

 

About to resort to the final straw of going to the local Sprint store and seeing if they'll try swapping out the BYOD SIM I picked up last week for another BYOD SIM and reactivating.

Share this post


Link to post
Share on other sites
crazy_vag    155

Where did you get the SIM for your phone?  I used the SIM that I had in my 6P and that SIM I purchased at Best Buy (since at the time, no Sprint Store had it in stock).  

 

I think you should save yourself time and just get a new SIM.  

Share this post


Link to post
Share on other sites
lordsutch    840

Where did you get the SIM for your phone?  I used the SIM that I had in my 6P and that SIM I purchased at Best Buy (since at the time, no Sprint Store had it in stock).  

 

I think you should save yourself time and just get a new SIM.  

 

Yeah, I'm going to the Sprint Store tomorrow to see if I can get another SIM. Tried doing a SIM swap online tonight but the system won't accept my old SIM since it's already associated with a device I guess.

Share this post


Link to post
Share on other sites
Oakley707    437

Somehow - very long story short - my Pixel XL seems to be provisioned for Sprint in such a way that it will only connect to 3G (the phone definitely connects to LTE with a Project Fi SIM installed on both Sprint and T-Mobile, so it's not a hardware problem). This has baffled everyone I've talked to at Sprint; we've tried everything (72787, PRL updates, device config updates...). In the hidden radio info screen I've tried wedging it into LTE-only mode and LTE cell information shows up under the "Cell Measurement Info," but for whatever reason it won't register on the network.

 

About to resort to the final straw of going to the local Sprint store and seeing if they'll try swapping out the BYOD SIM I picked up last week for another BYOD SIM and reactivating.

This sounds like the same problem I had with the Nexus 6 when i went to Project Fi.  Project Fi and Sprint do not play well together because they share services as you know.  When I activated Project Fi on my Nexus 6 AFTER I had my Nexus on Sprint it worked while on Project Fi, but when I tried to switch back to Sprint (was just test driving Fi) it would not re-activate.  Two weeks later after multiple store visits they found out that my phone's MEID was associated to Fi and that it wouldn't be removed from Fi's system thru Sprint.  So, I called Google and they were no help because it was VERY early on in the process.  I then went back to Sprint and they had to manually add my MEID (a two day process) which did eventually work.  I hope this is not your problem, as it was a real pain to troubleshoot / get a resolution.  Thankfully, persistence paid off.

  • Like 1

Share this post


Link to post
Share on other sites
ingenium    780

Anyone here get RCS enabled on their account yet? Is there a server side switch in addition to needing the latest version of Google Messenger?

 

Sent from my Pixel XL

Share this post


Link to post
Share on other sites
mtciii    59

Anyone here get RCS enabled on their account yet? Is there a server side switch in addition to needing the latest version of Google Messenger?

 

Sent from my Pixel XL

Not me, and yes.

 

Sent from my Pixel XL using Tapatalk

Share this post


Link to post
Share on other sites
MadTiger    16

Apparently, Pixel has significant connectivity issues: http://www.anandtech.com/show/10753/the-google-pixel-xl-review/7

 

"Normally we would also run this test on LTE, in order to compare battery life between devices when browsing on a cellular connection instead of WiFi. Unfortunately, the Pixel XL presents a problem here. Both Matt and I have noticed that cellular reception on the Pixel XL is not very good. In particular, Matt was unable to achieve our target signal strength of -90dBm or better in the same area where he tests all other LTE devices. The best signal he was able to achieve was -100dBm (outdoors). Because we're dealing with a logarithmic scale, the difference in transmission power is not 10% like you might imagine based on the numbers, it's ten times the power. Unfortunately, we aren't equipped to do laboratory tests on the Pixel XL to directly compare RF performance to other devices, but it does seem that the signal strength is generally not as good as other smartphones."

Edited by MadTiger

Share this post


Link to post
Share on other sites
liveToCheck    15

Anyone here get RCS enabled on their account yet? Is there a server side switch in addition to needing the latest version of Google Messenger?

 

Sent from my Pixel XL

 

Yes I got notified on Friday to enable enhanced features. Running a pixel XL on sprint.

Share this post


Link to post
Share on other sites
lordsutch    840

This sounds like the same problem I had with the Nexus 6 when i went to Project Fi.  Project Fi and Sprint do not play well together because they share services as you know.  When I activated Project Fi on my Nexus 6 AFTER I had my Nexus on Sprint it worked while on Project Fi, but when I tried to switch back to Sprint (was just test driving Fi) it would not re-activate.  Two weeks later after multiple store visits they found out that my phone's MEID was associated to Fi and that it wouldn't be removed from Fi's system thru Sprint.  So, I called Google and they were no help because it was VERY early on in the process.  I then went back to Sprint and they had to manually add my MEID (a two day process) which did eventually work.  I hope this is not your problem, as it was a real pain to troubleshoot / get a resolution.  Thankfully, persistence paid off.

 

Well, the latest development in the saga is I went to a Sprint store and we tried all sorts of things, including settings resets and swapping out SIMs, to no avail. I got in touch with someone on the Sprint community site who was helping people activate Pixels, so maybe that avenue will get it straightened out.

 

If that doesn't work I guess I'll complain to Google and see if they'll swap out the device for a fresh one that presumably will activate correctly on Sprint (unless they've messed up some deep magic in my account at their end).

Share this post


Link to post
Share on other sites
Oakley707    437

Well, the latest development in the saga is I went to a Sprint store and we tried all sorts of things, including settings resets and swapping out SIMs, to no avail. I got in touch with someone on the Sprint community site who was helping people activate Pixels, so maybe that avenue will get it straightened out.

 

If that doesn't work I guess I'll complain to Google and see if they'll swap out the device for a fresh one that presumably will activate correctly on Sprint (unless they've messed up some deep magic in my account at their end).

Have you asked to see if Google has released your MEID from their system?  Or have you asked Sprint to whitelist / add the device?  That was the hardest part to convince of either company and was a completely necessary step.

 

Good luck.

  • Like 1

Share this post


Link to post
Share on other sites
HTCandroid    245

Looks like all colors of the Pixel XL 32gb are currently expected to ship by November 23 for anyone who has been waiting for Google to replenish their supply chain. I'm currently waiting to see if they offer some sort of discount closer to Christmas as they did with the Nexus 6P (hoping they do a discount despite the Pixel's success).

Share this post


Link to post
Share on other sites
WiWavelength    31,437

FYI, staff will be relocating the last month of posts to the Google Pixel and Pixel XL users thread.

 

In the meantime, a month in to the life of the Pixel XL, a few thoughts...

  • An apt high concept description of the Pixel XL is the build of the HTC One M7 meets the screen of the 2015 Moto X Pure Edition meets the OS of the Nexus 5X.
  • Online activation of IMEI/MEID with reuse of my existing 3-in-1 UICC/CSIM went through without a hitch.  No customer service intervention necessary.  The online activation tool and account manager both immediately recognized the Pixel XL, correct color and and storage option.
  • The screen glass is 2.5D -- as all mid range and above screen glass should be -- and feels great to the touch.  The PenTile AMOLED screen has a green cast off angle.
  • The fingerprint reader can be finicky, especially regarding moisture, and its haptic feedback can be almost imperceptible at times.  The Nexus 5X fingerprint functionality feels more robust by comparison.
  • The Snapdragon 821 and 4 GB RAM combination is exceedingly snappy, handling day to day tasks with default encryption transparently, much more smoothly than does the Nexus 5X.  Along similar lines, the camera takes photos with almost zero shutter lag.
  • RF performance is typical for HTC -- quirky, at least, quirky on Sprint.  Some of the engineering screens are non functional; others, including the LTE engineering screen, periodically get stuck with stale or erroneous readouts.  Band 41 acquisition and retention are not up there with the best, such as the 2014 Moto X.  Overall LTE retention, though, is quite good, thanks to SRLTE performance, which is better than that of the Nexus 5X.  The Pixel XL regularly will engage SRLTE to bring in CDMA1X 800 to help retain LTE as well in low signal strength locations.
  • Battery power management is very good in frequent, everyday usage, holding up to web browsing and fantasy football updates every few minutes with a surprising amount of battery life still left at the end of the day.

AJ

  • Like 9

Share this post


Link to post
Share on other sites
skid71    148

Can someone share a link in which to order the 3-in-1 SIM kit for a Pixel XL?

Share this post


Link to post
Share on other sites
ingenium    780
Hmm, is it always discounted or is this just temporary? I got my BYOD for free when they first offered them, wondering if it's worth getting another to have around...

 

Sent from my Pixel XL

Share this post


Link to post
Share on other sites
lilotimz    10,869

Hmm, is it always discounted or is this just temporary? I got my BYOD for free when they first offered them, wondering if it's worth getting another to have around...

 

Sent from my Pixel XL

 

Oh you mean they didn't notice people ordering like a 100 free sims just because they could?

 

In store they're free IIRC. 

Share this post


Link to post
Share on other sites
ingenium    780

Oh you mean they didn't notice people ordering like a 100 free sims just because they could?

 

In store they're free IIRC.

Oh that's good to know. I may just ask for one next time I'm in one.

 

Lol and yeah, I did this for T-Mobile when they had free SIMs a few years ago. Bought 5 or 6, in all different sizes. I've actually used all but 1 of them (either personally or gave them away to people who needed one).

 

Sent from my Pixel XL

Share this post


Link to post
Share on other sites
Nrbelex    146

Has anyone noticed their device dropping from a perfect LTE signal to no signal, momentarily, then returning to full signal? This has occurred for me since I got the device (regular Pixel). This happens many times a day during active usage in multiple major markets.

 

Not sure if it's just a software bug, maybe related to this one, which will be patched soon, a Sprint network problem, a tower hand-off issue, a SIM card problem, or a device problem. If the last of those, I want to RMA quickly.

 

Thoughts? Thanks!

Share this post


Link to post
Share on other sites
mtciii    59

Has anyone noticed their device dropping from a perfect LTE signal to no signal, momentarily, then returning to full signal? This has occurred for me since I got the device (regular Pixel). This happens many times a day during active usage in multiple major markets.

 

Not sure if it's just a software bug, maybe related to this one, which will be patched soon, a Sprint network problem, a tower hand-off issue, a SIM card problem, or a device problem. If the last of those, I want to RMA quickly.

 

Thoughts? Thanks!

Saw it happen yesterday but that was actually the first time I noticed it in the six weeks I've had the device.

 

Sent from my Pixel XL using Tapatalk

Share this post


Link to post
Share on other sites
Nrbelex    146

Saw it happen yesterday but that was actually the first time I noticed it in the six weeks I've had the device.

 

Sent from my Pixel XL using Tapatalk

 

I noticed it most while on a fast-moving train, and moving through NYC -- both situations where I would expect frequent handoffs. I haven't seen it nearly as much when I'm stable.

 

Thanks for the data point.

Share this post


Link to post
Share on other sites
mtciii    59

I noticed it most while on a fast-moving train, and moving through NYC -- both situations where I would expect frequent handoffs. I haven't seen it nearly as much when I'm stable.

 

Thanks for the data point.

Sure thing. It was actually a weird time for it. I was just in my living room, dropped B41 completely, and then picked up B25. It switched back to B41 without first dropping connection.

Share this post


Link to post
Share on other sites
Nrbelex    146

FYI: there is an increasing number of people on the Pixel forum reporting the exact issue I'm experiencing—complete loss of signal, seemingly when handing off between towers.

 

To recap:

 

I've seen this issue routinely in DC and NYC on Sprint. I've tried re-seating the SIM, resetting the network settings, updating my CDMA profile and the PRL, all with no effect.

It definitely appears related to tower hand-offs, maybe involving Band 41 specifically. Was hoping the 7.1.1 update would resolve it, but it sounds like that won't happen. I was also considering a factory reset or an RMA, but from those above, that sounds hopeless.

Share this post


Link to post
Share on other sites

I've been having the LTE dropping issue extensively since day one with my Pixel XL.  Happens when fast moving (car), slow moving (run), and still at my house.  I can consistently get it to happen just walking from the front of my house to my back alley (seems to switch towers).  Switching to 3G COMPLETELY alleviates the problem.  Not a single drop anywhere.

 

Spoke with Google, who was useless (told me to get a new SIM, check some settings, talk to Sprint.)  I did these, emailed them back, and they told me to talk to Sprint again.

 

Sprint has tried, but been less than helpful thus far.  Spoke with tech support who had me try to reprovision a number of times (they kept giving me HTC dialer codes which didn't work, which baffled them).  They put in a request to check the towers near my home, but this isn't something that only happens there.  I did notice (by driving around with Signalcheck open) a nice long stretch the other day where I had multiple tower changes and no drop at all.  I've been meaning to look at the tower maps to see if perhaps there's some correlation.

 

I had this type of problem way back when LTE was just rolling out with my Nexus 5 too.  I've got drops with my XL in a number of the same places, though, never had the problem in the slightest with my Nexus 5X.

Share this post


Link to post
Share on other sites
crazy_vag    155

I've been having the LTE dropping issue extensively since day one with my Pixel XL.  Happens when fast moving (car), slow moving (run), and still at my house.  I can consistently get it to happen just walking from the front of my house to my back alley (seems to switch towers).  Switching to 3G COMPLETELY alleviates the problem.  Not a single drop anywhere.

 

Spoke with Google, who was useless (told me to get a new SIM, check some settings, talk to Sprint.)  I did these, emailed them back, and they told me to talk to Sprint again.

 

Sprint has tried, but been less than helpful thus far.  Spoke with tech support who had me try to reprovision a number of times (they kept giving me HTC dialer codes which didn't work, which baffled them).  They put in a request to check the towers near my home, but this isn't something that only happens there.  I did notice (by driving around with Signalcheck open) a nice long stretch the other day where I had multiple tower changes and no drop at all.  I've been meaning to look at the tower maps to see if perhaps there's some correlation.

 

I had this type of problem way back when LTE was just rolling out with my Nexus 5 too.  I've got drops with my XL in a number of the same places, though, never had the problem in the slightest with my Nexus 5X.

 

Probably a regression from the latest Dec update.... 

 

 

Hopefully you can last until January, so Google rarely does out-of-cycle updates.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • PROGRESSIVE RAFFLE
    FOR AN iPHONE 8

    iphonexiphone8.jpg

    WHICH CAN PROGRESS TO AN iPHONE 8+ OR AN iPHONE X
    **or an Android device of equal or lesser value**

    CLICK HERE FOR MORE DETAILS

  • gallery_1_23_9202.png

  • Posts

    • I've had my Unlocked Coral Blue GS8+ since end of July and it's still going strong.  No software issues or weird shenanigans.  I attribute a lot of that to being on the Unlocked 955U1 firmware.  I still kept my 935U Galaxy S7 Edge and it too is going strong on the Unlocked firmware.   I think most of these issues are coming from Sprint messing with the ROM too much with their bloat and other crap. The only issue I've had so far was when Google updated their Google app, my battery began to drain a lot faster - ~5%/hr instead of the normal ~2%/hr.  A simple reboot took care of that.  Google is still my NUMBER ONE enemy for battery life.  I"m hoping Oreo will take care of Google.
    • FFS.      Now the power supply for our MB has seemingly failed.  When I first plugged it in, I thought the power supply seemed overly ‘noisy’ in that it made a constant hiss/buzz.  Woke up this morning to 2 bars of 1x, and the MB indicated it needed to be plugged in.  Receptacle tested fine.  Power Supply no longer makes any noise and smells a little suspect so Sprint is sending a replacement.  
    • you should get the phone! it has a amazing camera and the battery life ins phenominal!
    • I'm thinking they've closed off residential requests for now until they fill some of the orders. I know the link is around here somewhere, Google Sprint magic box, or try sprint.com/magicbox Currently, last I heard, it was business only...  
  • Recently Browsing

    No registered users viewing this page.

×