Jump to content
drhenning

AirRave not supported on GS5 in default mode

Recommended Posts

Just discovered this when I returned to my other home that has an AirRave...  If my Spark device (S5) is in default mode of LTE, it will not see my AirRave and it needs to connect to a local tower that gives me mediocre voice quality. .. The solution is to kick it back to CDMA mode when I'm home to assure better quality from my AirRave and then switch back to LTE when I leave.... 

 

I was told they are working on a solution which may ultimately be WIFI calling...  Then I can get rid of the AirRave...

 

 

Share this post


Link to post
Share on other sites

My Nexus 5 is the same way. It latches on to really weak LTE at home and won't fall back to the Airave unless I put it in 3G only mode. Luckily here CDMA 800 is being deployed, and as long as I connect to it I don't need the Airave. I'll probably be returning mine once the area is officially launched.

 

Sent from my Nexus 5 using Tapatalk

Share this post


Link to post
Share on other sites

The other thing coming this year is WIFI calling directly on the phone as an option...  I was also told by the Sprint sales store across the street from my condo in Charlotte that they are adding a tower fairly close by as well which should help coverage...

Share this post


Link to post
Share on other sites

The other thing coming this year is WIFI calling directly on the phone as an option...  I was also told by the Sprint sales store across the street from my condo in Charlotte that they are adding a tower fairly close by as well which should help coverage...

the S4 and the Note 3 already have it, im surprised that the S5 didnt have it out of the box.

 

It works really well... it will certainly remove the need of an Airwave altogether 

 

I imagine it will be on OTA update really soon for the S5

Share this post


Link to post
Share on other sites

if you have an lte device and an airave you need to put the phone in cdma only mode then your phone will work with the airave.

Share this post


Link to post
Share on other sites

Well.....  I retract this problem since my phone has learned to work correctly with my AirRave the last couple of weeks...  No need to flip to CDMA only mode anymore...  It has its data needs handled by the WIFI and now keeps the LTE off and uses my AirRave for calls and texting..

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×